[CentOS] Printing Postscript - Very Weird Problem.

Fri Jan 13 23:08:29 UTC 2006
C.M. Connelly <cmc at math.hmc.edu>

"MZ" == Maciej Żenczykowski <maze at cela.pl>

    MZ> Hey folks, okay, here's the situation - I have a Centos
    MZ> 4.2 system with cups printing installed printing via
    MZ> postcript (with appropriate PPD file) to a HP LaserJet
    MZ> 1320N printer (via jetdirect socket 9100).

I have the same setup....

    MZ> Everything seems to work right - except for an unusual
    MZ> 'font'??? problem.  Many letters seem to be just slightly
    MZ> garbled.  

I have also seen this problem, generally when printing a PDF file
(generated with TeX) from gv.  If I open the file in Acrobat, it
prints fine.

I just tried generating some PostScript by piping the output of a
command that produces ASCII through ``a2ps -1'', and I see no
issues with the printout.

If I take a simple LaTeX document and TeX it, producing a DVI file;
then run dvips to produce a PostScript file and print that file
From gv, I see no issues.  On the other hand, if I run that same
PostScript file through ps2pdf, then open the PDF file in gv and
print it, I see the broken/malformed character issue.

Running pdflatex on the source file to get a PDF file gives the
same results: looks fine on screen, prints with broken/malformed
characters from gv; prints fine from Acrobat.

I had the very same problem with a LaserJet 1200 connected via a
parallel cable under CentOS 3 a while back, and never really
figured out what the deal was beyond this point.  The obvious
candidate is GhostScript, or gv's use of GhostScript to generate
PostScript from the PDF file.

Sorry I can't be more specific about what the cause is or a better
solution, but at least you know you're not alone in having the


P.S. On Will's question -- self tests work fine.  It's definitely
     not the printer, unless it's some weird interaction between
     its emulated-PostScript interpreter and GhostScript.

  Claire Connelly                              cmc at math.hmc.edu 
  Systems Administrator                          (909) 621-8754   
  Department of Mathematics                 Harvey Mudd College
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 188 bytes
Desc: not available
URL: <http://lists.centos.org/pipermail/centos/attachments/20060113/379cb10a/attachment-0004.sig>