[CentOS] freenx

Tue Jan 24 06:38:48 UTC 2006
Craig White <craigwhite at azapple.com>

On Tue, 2006-01-24 at 00:24 -0600, Jaymz Ringler wrote:
> On Mon, 2006-01-23 at 22:38 -0600, Les Mikesell wrote:
> > On Mon, 2006-01-23 at 22:06, Craig White wrote:
> > 
> > > > I think you have a problem with the client or key.  If I alter
> > > > the key I don't see any log entry for the failure.
> > > ----
> > > I might be inclined to agree with you but 
> > > 
> > > #
> > > diff /etc/nxserver/client.id_dsa.key /var/lib/nxserver/home/.ssh/client.id_dsa.key
> > > [root at srv1 nxserver]#
> > 
> > I'm not quite sure what you are comparing here.  The installed
> > key on the client ends up in
> > $HOME/.nx/config/server_name.nxs along with some other stuff.
> > It's text - compare the key entry to the current one on
> > the server in /etc/nxserver/client.id_dsa.key.
> > 
> > > I find it hard to believe that anyone actually has made it work.
> > 
> > I've had no problem other than having to paste the correct
> > key for each server and having some sessions that look like
> > they should resume but won't.  I've only run the client on
> > FC1 and windows and the server on Centos and FC4.  Maybe
> > there is something odd about a client on FC4.
> > 
> I run nxclient on multiple fc4 desktops which connect to multiple centos
> 4 servers and all work all the time.  That isn't an issue..
> I can't think of what it could be...   when ever I set up freenx on a
> machine for remote access.  
> I install the rpms on the host. then copy
> the /etc/nxserver/client.id_dsa.key as hostname.id_dsa.key then scp it
> to the client machine. I also copy the .key to a flash drive for further
> importing to other clients.  
> I install the nxclient rpm on the client machine.   Configure a new
> connection.   click on the import key button..  point to the key either
> scp'd or on the flash drive...  save it and it's always worked.
> I too have a couple machines that have root ssh cert's between the two
> and I still had no problems.    
I appreciate everyone's help on this (thanks Les)

It's either my setup, my methodology or the packaging as it currently
sits...current clients from nomachine.com connecting to current server
packages nx/freenx from CentOS...that doesn't work.

Since I have never made it work before, I am more likely to believe that
it is me but I have documented all my steps and tried to incorporate
everyone's advice on this and am shifting my thinking that it isn't me -
that someone else would not be able to make it work installing freenx/nx
from CentOS and current clients from nomachine.com (I've tried Windows
and Linux).