[CentOS] freenx [SOLVED]

Tue Jan 24 15:25:33 UTC 2006
Craig White <craigwhite at azapple.com>

On Tue, 2006-01-24 at 10:33 +0100, Maciej Żenczykowski wrote:
> > copied the above key (that which was between the ----BEGIN and -----END
> > but not including those lines) and pasted into the key section and that
> why without the --begin-- --end-- lines?  I always copy with'em.
Yeah - I think I needed them too. I was unsure which is why I posted up
about copying the key with/without them. Turned out 'importing' probably
would have worked just fine too - have to check on that.

> I generate keys using ssh-keygen, and stick them into:
> /var/lib/nxserver/home/.ssh/authorized_keys2
> (or without the '2' depends on sshd server setup)
> [in one line] and the entire private key into the client.
This little nugget combined with what I learned last night was the key
and I probably would have stumbled into last night had I had the
----BEGIN & -----END lines.

turns out that install will create


but sshd on CentOS 4 doesn't look there.

so I merely

cd /var/lib/nxserver/home/.ssh
cp authorized_keys2 authorized_keys
chown nx authorized_keys

et voila - login

Thanks for everyone's help

I can't believe that people didn't stumble into this installing freenx
on CentOS as it simply cannot work out of the box without doing this or
some other change in /etc/ssh/sshd_config