[CentOS] postfix conf for use external smtp

Fri Jul 14 18:34:04 UTC 2006
Guillermo Garron <guillermo.fedora at gmail.com>

Hi all,

i wonder how to configure postfix make it use externa smtp server i tried
the following

relayhost = my.stmp.com
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_auth_enable = yes
smtp_sasl_security_options = noanonymous
smtp_sasl_tls_security_options = $smtp_sasl_security_options
smtp_use_tls = yes

i have

my.smtp.com user:password

then i
postmap /etc/postfix/sasl_passwd

restart the postfix, but now i have this problem.

Jul 14 12:06:33 garron postfix/smtp[8510]: ECA31F3009D: to=<
ggarron at hotmail.com>, relay= my.smtp.com, delay=2, status=deferred
(Authentication failed: cannot SASL authenticate to server scz.alketech.com[ 3]: no mechanism available)

i tried with

smtp_sasl_security_options = noanonymous
smtp_sasl_security_options = noplaintext, noanonymous
smtp_sasl_security_options =
but never works, with the second i got the error up. with the other it does
not even try to login.

i also saw this.
when i issue this command as root

 postmap -q my.stmp.com hash:sasl_passwd
i go this error

Jul 14 13:12:13 garron postfix/postmap[9123]: fatal: open database
sasl_passwd.db: Permission denied
i tried even with 777 permissions

any clues?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos/attachments/20060714/a8996cf8/attachment-0004.html>