[CentOS] Re: How Undo Yum Upgrade

Maciej Żenczykowski maze at cela.pl
Sat Mar 4 13:28:13 UTC 2006

> rpm --test --oldpackage -Uvh  *.rpm
> error: Failed dependencies:

>        libselinux >= 1.23.10 is needed by (installed) 
> rpm-python24-4.4.2-11_9.el4.at.i386

this is probably uninstallable :)  try the rpm --test --oldpackage... 
command for each rpm you have in turn, some of them should work out, 
afterwards the 'rpm-python24' rpm will probably be removable (ie it will 
no longer be needed by anything).

>        libselinux = 1.23.10-1.99_3.el4.at is needed by (installed) 
> libselinux-devel-1.23.10-1.99_3.el4.at.i386

uninstall libselinux-devel (devel's are only needed for compiling you can 
yum install it later once everything is working)  just write down on a pad 
what devel's you uninstall :)

>        libxml2 = 2.6.22 is needed by (installed) 
> libxml2-python24-2.6.22-1_22.el4.at.i386

as the first package

>        neon = 0.24.7-5.99_2.el4.at is needed by (installed) 
> neon-devel-0.24.7-5.99_2.el4.at.i386

uninstall neon-devel...

>        rpm = 4.4.2 is needed by (installed) 
> rpm-python24-4.4.2-11_9.el4.at.i386

as the first package

>        rpm = 4.4.2-15.1_58.el4.at is needed by (installed) 
> rpm-build-4.4.2-15.1_58.el4.at.i386

don't you have rpm-build in the *rpm's

so you want to first install an older rpm rpm and any dependecies that may 
force, and only afterwards mess around with the rest ;)


More information about the CentOS mailing list