[CentOS] Help with installing on Supermicro X6DHT-G server Marvell H2 SATA

Joshua Baker-LePain jlb17 at duke.edu
Sat Mar 11 12:58:12 UTC 2006

On Sat, 11 Mar 2006 at 8:13am, Chris Mason (Lists) wrote

> I am trying to build a file server with 1 x 80 GB main drive and 4 x 500 GB 
> SATA drives in RAID in a Supermicro 3U server.
> I found out the hard way that Centos 4.2 does not have a driver for the 
> onboard Marvell H2 controller the drives are connected to.
> Supermicro techs sent me aar81xx.rhel4qu2.i686.img as an img file. I used dd 
> to copy to a floppy and dd confirmed successful write.
> I booted Centos 4.2 and chose linux dd. When prompted I inserted the floppy 
> and the driver was loaded. However, when it came to partitioning the drives, 
> no drives could be found. I tried loading the driver during install using F2 
> for "other drivers", still no go.
> Has anyone had success with this process or am I doing it wrong? The img file 
> can be downloaded from http://www.masonc.com/aar81xx.rhel4qu2.i686.img if 
> anyone would like to test it.

I would strongly recommend *not* using that SATA controller at all.  Your 
problems with it aren't going to end once you get the install done.  The 
driver from SuperMicro is not going to track the vendor kernel closely at 
all, so you'll be forced to not install kernel updates.  Also, given that 
the driver isn't in the kernel, its performance and stability are 

On my compute nodes with SM boards, I just threw a 3ware 8006-2 in each 
and a single drive.  On my servers, I used the same controller and a pair 
of 74GB WD Raptors as a hardware RAID1.  The 3w-xxxx driver is rock solid 
and has been in the kernel for a long while.

What controller are you using for the 4 drive RAID array?  Would it be 
possible to boot off that?

Joshua Baker-LePain
Department of Biomedical Engineering
Duke University

More information about the CentOS mailing list