[CentOS] alsa 1.0.11rc3 on AMD 64

Jerry Geis geisj at pagestation.com
Mon Mar 13 16:03:45 UTC 2006

Any one try alsa 1.0.11rc3 on AMD 64?

I download drivers, library and utils.

I did ./configure; make; make install for drivers. worked fine.
I did ./configure; make; make install for libs. worked fine.
I did ./configure on utils worked fine.

on doing a make I get the following errors below.

I did try the alsa mailing list first... All I got there was it worked 
on their linux

Any ideas on why the utils compile is failing. drivers and libs worked fine.




Making all in alsactl
make[1]: Entering directory `/usr/src/alsa-utils-1.0.11rc2/alsactl'
gcc  -g -O2   -o alsactl  alsactl.o state.o power.o names.o  -lasound 
-lm -ldl -lpthread
state.o(.text+0x53b): In function `get_control':
/usr/src/alsa-utils-1.0.11rc2/alsactl/state.c:185: undefined reference 
to `snd_ctl_elem_info_is_user'
state.o(.text+0x1b3c): In function `add_user_control':
/usr/src/alsa-utils-1.0.11rc2/alsactl/state.c:724: undefined reference 
to `snd_ctl_elem_add_boolean'
undefined reference to `snd_ctl_elem_add_iec958'
undefined reference to `snd_ctl_elem_add_integer'
names.o(.text+0xe1b): In function `probe_timers':
/usr/src/alsa-utils-1.0.11rc2/alsactl/names.c:428: undefined reference 
to `snd_timer_ginfo_sizeof'
undefined reference to `snd_timer_ginfo_sizeof'
undefined reference to `snd_timer_ginfo_set_tid'
undefined reference to `snd_timer_ginfo_get_name'
collect2: ld returned 1 exit status
make[1]: *** [alsactl] Error 1
make[1]: Leaving directory `/usr/src/alsa-utils-1.0.11rc2/alsactl'
make: *** [all-recursive] Error 1

More information about the CentOS mailing list