[CentOS] YUM update from RHEL3 to CentOS3 stalls

iank at mac.com iank at mac.com
Mon Mar 13 22:45:27 UTC 2006

OK, I got it solved.

Thank goodness for a screen that scrolls back a long way!!

I was able to pull the install order from the console output (note
to self, sending a copy of the console messages to a file would be a
good thing). From there I was able to determine what was left off,
and the proper order run through.

Probably the best method would be to do the following:

*Work backwards from the last RPM downloaded.
*Since the rpm name might be truncated, do a "rpm -qa | grep rpm name"
*You should see 2 versions, the old one and the new one (since the 
  process itself completed).
*Do a "rpm -e --justdb newer rpm name"
*Continue through until you reach the transaction that failed.
*Do a "yum update rpm name" from that point back down the list in the
  correct order of the downloads.

This will back out just the rpm database entry, and allow you run the 
transaction correctly, including all pre/post/postun scripts.

Some thoughts:

Once you back out all the database entries, you could probably just run
"yum update" which should catch everything that you need.

I didn't back things out in the reverse order, but worked from the 
point on. In hindsight, this is probably what led to a few dependency 
which required the --nodeps flag.

A script might work out nicely, but I wanted to watch each transaction 



More information about the CentOS mailing list