[CentOS] strange network problem

Patrick centos at puzzled.xs4all.nl
Thu Mar 16 11:20:54 UTC 2006

On Thu, 2006-03-16 at 02:16 -0800, Jack Bailey wrote:
> >> I can't figure this one out.  There's a Belken USB->Ethernet adapter as
> >> eth2 on my server.  After a reboot it doesn't communicate with anything
> >> ever though it's up:
> >> bounce the interface:
> >>
> >> # ifconfig eth2 down
> >> # ifconfig eth2 up
> >>
> >> now it works:
> >>     
> >
> > I don't know anything about how the USB->Ethernet dongle's setup
> > (kernel modules etc.) but does it require something to be started
> > that's not being run until after S10network in the init scripts?
> >
> > Are there any errors in /var/log/messages or dmesg for ethernet or USB devices?
> No errors that I can see.  CentOS saw the device when I plugged it in,
> and after configuring it, it worked.  It stops working after a reboot,
> but will come up and begin working once again after I bounce the interface.

I had a similar issue the other day. Appareantly the nic and the switch
did not agree on things. Check with ethtool if the nic is set to the
right speed etc. If you see 10Mbit/s & half duplex it's likely they
messed up negotiating something sensible. Set/force the right settings
on either the nic or the switch. Iirc it's best pratice to not use
autonegotiate on e.g. a switch to prevent these things from happening.

Hope this helps.


More information about the CentOS mailing list