[CentOS] LVM Snapshots -broken ? Ever worked ?

Bards1888 bards1888 at gmail.com
Thu Mar 16 11:33:25 UTC 2006

I've upgraded my x86_64 4.2 box to the latest kernel and tried
an lvm snapshot. It worked fine and I was able to mount the snapshot
etc. Now I cannot seem to remove the snapshot.   If I try a 'lvremove'
it asks if I want to remove the 'active' snapshot, if I say yes it just
hangs and the box goes to 99% wait io, however the disk lights do not
come on during this. The lvremove process is not straceable so I've got
no idea whats going on with it.

Luckily I  chose to snapshot /tmp so it is not a show stopper. What I
did to get around it was to comment out my tmp lv from fstab and just
allow /tmp to be part of the root filesystem on the root lv.  I
deliberately filled up the snapshot so that it was marked inactive but
it still thinks it is active when I run the lvremove command again. I
also tried to lvremove the tmp lv, not the snapshot, and it  said it
couldnt remove the lv while there was a snapshot.

I found a thread on the forums where Karanbir Singh states that this
sort of thing was broken in early 4 series but may work in 4.3.

Does anyone know how I can clean this up ?



More information about the CentOS mailing list