[CentOS] phpMyAdmin login problems

rado rado at rivers-bend.com
Mon Mar 20 02:02:27 UTC 2006


running 4.2 and the latest stable phpMyAdmin of course all the
lamp stuff is running. 

Alexander Dalloz helped me a good bit on the installation which I am
truly gratefull. And then I brought it to a point where I can log on
from local as any user and give it the anon's password and phpmyadmin
will come up w/of course no privileges.

I can log on as root from local w/the password and it will come up as
root should w/all privileges.

coming in from the web is a different story: if one tries to log on from
the web to the following url and msg:
   The URL is this:


  The Browser page shows this:

You don't have permission to access /phpmyadmin/index.php on this


Apache/2.0.52 (CentOS) Server at rivers-bend.com Port 80

ok this is 1 of 3 problems I can't seem to get a handle on.

2.Well, ...trying to go by the book...I have anon users all to the same
password and root having it's own. I am having trouble having a user
w/his own password to have special privileges, i.e. to have control over
his own database.

I have even tried to set it up in phpmyadmin as root through privileges
but no dice.

this same user can log on w/his user name and the anon password tho.

3rd and last problem: mysql: mind you I am still trying to get the
passwords staight and I know next to nothing about mysql yet. but there
is reference to "host" and in the mysql.user file ...well, you know how
everything is spelled out in localhost and then in "host" in my case
it's rbmain1.rivers-bend.com. What I am concerned about is that I run 2
servers mirroring each other and really makes no difference who's got
the ball. the other server is rbmain2 but I am hoping this will take
care of itself down the line.

whew! I'm sorry for all this. geez

thx y'all

John Rose

More information about the CentOS mailing list