[CentOS] kannel from dag - sqlite conflict with centos 4.2

Fajar Priyanto fajarpri at cbn.net.id
Mon Mar 20 08:48:31 UTC 2006

On Monday 14 November 2005 05:20 pm, Tony wrote:
> Dag- there are no internal file conflicts between the two sqlite rpms - I
> solved my problem with "rpm -ivh sqlite-3.2.2-1.i386.rpm" and now have both
> sqlite packages happily sitting side by side. The problem came earlier when
> an up2date -u wanted to replace your sqlite package with the new
> centos 4.2one- but your kannel package needs your sqlite as the new
> package is really
> sqlite3. RHEL users of your kannel package won't be affected, and hopefully
> any other centos4 users will find this mail thread or have solved it for
> themselves way faster than I did. If you rebuild your kannel against the
> new centos sqlite library then you break RHEL users. I suppose you could
> change your sqlite package to be called sqlite2 to avoid the clash, but I
> guess that would give you all sorts of other dependency changes elsewhere
> in your repo.
> I don't know enough about how packages obsolete each other. Maybe the
> problem is that the FC/centos4 sqlite rpm should have something in it to
> say that it doesn't obsolete sqlite versions < 3?

Hi Tony, I am trying to install kannel too on Centos 4.2.
But unfortunately I'm not following you.

What steps should I do to install it?

This is the steps that I have tried:
1. Install using yum from dag, it complained about missing dependencies: 
2. Download and try to install sqlite2 manually using rpm ivh, but it says 
that there is newer version already installed.

Fajar Priyanto | Reg'd Linux User #327841 | Linux tutorial 
15:48:30 up 7:14, 2.6.15-1.1830_FC4 GNU/Linux 
Let's use OpenOffice. http://www.openoffice.org

More information about the CentOS mailing list