[CentOS] USB key problems on enterprise systems

Lawrence Houston centos at greenfield.dyndns.org
Mon Mar 20 15:01:55 UTC 2006


On Mon, 6 Mar 2006, Lawrence Houston wrote:

> On Fri, 3 Mar 2006, Collins Richey wrote:
>> Just came up with some interesting (read: frustrating) problems on
>> RHEL3 and RHEL4 today at work, and I've confirmed one of the problems
>> on my up-to-date CentOS4 system at home. I was forced into releasing
>> some RHEL3 systems to replace our aging RH9 systems without time for
>> adequate testing, and that leads to problems like these.
>> On our legacy RH9 systems, mounting a USB key is no problem, but I
>> can't get it to work on either RHEL3-U6 or RHEL4-U2 (= CentOS4). I'm
>> curious if any CentOS3 or CentOS4 users have any suggestions.
> Last week I noticed similar problems with USB Flash/External Drives failing 
> to Automount under RHEL3-U6/CentOS3.6, so your Posting caught my attention. 
> Curiously within CentOS's Archives for some people USB Device Automounting 
> works and for others it does NOT, so I decided to revisit CentOS4 (since it 
> uses a different mechanism for its USB Hotplugging)...
>> Here are the results from plugging in a USB Key and trying to mount it:
>> 1. On RHEL3-U6, some systems get the following, and there is a workaround:
>> Message: USB device not accepting new address
>> Workaround: /sbin/modprobe -r ehci-hcd
>> Message: READ CAPACITY failed
>> ...
>> Unable to read partition table
>> Workareound: none that I am aware of. The above workaround has no effect.
> With RHEL3-U6, CentOS 3.5 "clean" (then upgraded to 3.6) adding appropriate 
> entries to /etc/updfstab.default atleast kudzu creates a mount point within 
> /mnt and adds the correct entry to /etc/fstab, although still NO 
> Automounting...  From there "mount /mnt/???????" or running "Disk Management" 
> successfully mounts the USB Flash/External Drives.  Although it was noted 
> that the kudzu generated entries do NOT always appear with "Disk 
> Management"'s List, although the command-line mount still worked???

More recently I tried RHEL3-U7, as with RHEL3-U6 Mount Points are created 
and FSTAB Entries are added, but still NO Automounting...  Possibly that 
is by design with RHEL3/CentOS3???

>> 3. RHEL4-U2 and CentOS4 get the following:
>> No possibility to mount. As soon as you plug  in the USB key, the
>> system goes into a SCSI error loop until you unplug it.
>> I've googled extensively for an answer, found a few hits for the RHEL3
>> problem, but no useful solutions.
>> The RHEL4 problem is apparrently a 2.6 kernel bug. Doe anyone know of
>> a packaged kernel solution for this? I'm using the CentOS unsupported
>> kernel at home, but same problem as in the stock RHEL4 kernel. Have RH
>> possibly fixed this in the U3 beta?
>> In case you're wondering about the key(s), the mount works flawlessly
>> including KDE automounting the key on my Kubuntu Dapper development
>> system with kernel 2.6.15-16-386 #1 PREEMPT.
> Under CentOS4 my results were different...  With CentOS 4.1 "clean" 
> Automounting of my Kingston USB Flash Drive actually worked, the Drive ICON 
> appeared on the Desktop (GNOME) and its contents could be viewed once the 
> Drive ICON was opened!!!  Additionally the Flash Drive could be Unmounted 
> from within the ICON's Properties...
> Unfortunately after a full upgrade to CentOS 4.2 the Automounting no longer 
> worked and the System Logs now recorded some dbus Error Messages about being 
> unable to report warnings (this had NOT been the case with the "clean" CentOS 
> 4.1)!!!  Additionally with the "upgraded" CentOS 4.2 "Removable Storage" 
> fails to run: claiming "hald" (HAL Daemon) was not running, when it fact it 
> was???  Under the "upgraded" CentOS 4.2 I also tried the CentOSPlus (per 
> Johnny's suggestion) and found the same problems (whether the "clean" CentOS 
> 4.1, the stock "upgraded" CentOS 4.2 or "Plus" CentOS 4.2 Kernels were 
> used)...

With the above RHEL3-U7 upgraded to RHEL4-U3 the Automounting is back to 
working, as it had under CentOS4.1 (before being upgrade to CentOS4.2)... 
I am curious to see how CentOS4.3 performs once it is released???

>> Collins Richey
>>      The agnostic dyslexic insomniac lies awake wondering if there is a 
>> dog.
>> _______________________________________________
>> CentOS mailing list
>> CentOS at centos.org
>> http://lists.centos.org/mailman/listinfo/centos

Lawrence Houston  --  (centos at greenfield.dyndns.org)

More information about the CentOS mailing list