[CentOS] Re: installing yum on RHEL 7.2

Scott Silva ssilva at sgvwater.com
Mon Mar 20 20:57:42 UTC 2006

Nick Smith spake the following on 3/20/2006 12:45 PM:
> im very new to RH, and even more so to YUM, but i need to install it
> on a RHEL 7.2 server, which i have done but installing the RPM
> package, and updated it via the Centos2 archives.  The program i am
> trying to install is bacula, a backup/tape program on one of our old
> servers, we need to upgrade to a newer version.  I didnt want to deal
> with the deps, so i thought yum was the way to go.  well, it cant find
> bacula, and i even downloaded the rpm from their website, and tried to
> get yum to install it that way "yum install bacula.rpm" and that
> doesnt work either, i get a:
> # yum install bacula-mysql-1.38.5-4.101mdk.i586.rpm
> Gathering package information from servers
> Getting headers from: CentOS-2 base
> Getting headers from: CentOS-2 updates
> Finding updated packages
> Downloading needed headers
> Cannot find a package matching bacula-mysql-1.38.5-4.101mdk.i586.rpm
> can anyone shed some light on this for me? im kinda lost here.  ive
> googled and found some good centos docs, but it doesnt solve my
> problem, the "localinstall" switch i guess is not supported anymore
> according to something i read on the net, and it doesnt work either
> when i try it.
> how can i get this installed with something that will handle the deps
> for me?  am i even asking the right question? thanks for any help you
> can give.
> Nick
You are trying to install a Mandrake RPM onto RedHat, which will probably muck
up things. And using CentOS 2 to patch RedHat 7.2 will probably do more "nasty
things". Maybe if you tried to rebuild a source rpm?

Try this version of Yum;
And you might be able to get closer to current. Although Fedora Legacy dropped
7.2, the files seem to still be available.
Will updating this box to at least 7.3 break anything?
There is still legacy support for 7.3, but who knows for how long.

More information about the CentOS mailing list