[CentOS] httpd not starting after 4.3 update

Johnny Hughes mailing-lists at hughesjr.com
Thu Mar 23 13:19:31 UTC 2006

On Thu, 2006-03-23 at 07:35 -0500, Jerry Geis wrote:
> On Thu, 2006-03-23 at 01:13 -0500, Jerry Geis wrote:
> >/ After updating to 4.3 I cant get httpd to startup.
> />/ I see no messages in /var/log/message other that httpd failed.
> />/ 
> />/ I see no errors in /var/log/httpd/error_log
> />/ 
> />/ there is mention in ssl_error_log that no RSA or DSA certificate is found.
> />/ I dont know what to do about that.I tried starting in the  non fork mode
> />/ but all it does is give me a prompt no error message .
> />/ 
> />/ Also of note I am having issue with sshd. It starts up but I cannot connect
> />/ to the machine.
> />/ 
> />/ I have been at this for a couple hours now. trying anything...
> />/ 
> />/ Jerry
> /
> >Please look hard at your selinux.  I suspect that is where your problems
> >lie if it is turned on.
> Johnny and all,
> My selinux is turned off.
> doing rpm -qa | grep httpd does not show duplicate packages.
> Is there a way to "freshen" the new packages for 4.3. Kind of a way to reload the 
> packages without SCRAPPING the partition and starting from scratch? just a thought.
> Is there someway to tell what httpd doesnt like? When I run httpd with options to
> check config files and things like that it runs an prints a couple lines and prints 
> status OK. So the exe is running just not as a background process.
> Thanks 
> Jerry

Seems to me that you had a problem generating the ssl keys for this and
sshd ... (by what I read before).

Removing and reinstalling these pacakges should help.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.centos.org/pipermail/centos/attachments/20060323/f7cc3022/attachment.bin

More information about the CentOS mailing list