[CentOS] yum, dag and xawtv

Damian Sobieralski dsobiera at asu.edu
Thu May 4 19:36:20 UTC 2006


Hi,

 I'm a newbie with CentOS. Actually, with this generation Linux.  I used
it back in the middle 90's (Debian and Slackware) but migrated over to
FreeBSD.  I got tired of the dependency nightmares and wanted a system
that "just worked". The FreeBSD ports system did just that for me. I
HATE doing the rpm soup thing.  RPM finders are nice but I'd rather just
use something like the FreeBSD port system to handle all dependency
issues for me.

 But I've slid back into Linux and found CentOS.  Boy, have things
changed a bit since I was last here :)  I have to admit, yum gives me
that functionality that I was very happy with FreeBSD - the ports
system. It's not exactly the same but I LIKE yum a lot!  I am noticing a
couple of problems dealing with YUM that I hope you can help me with.

 I noticed that the default CentOS repositories that came on an install
had a lot of the common packages but stuff like audacity and xawtv
weren't there.  But I figured that there was a repository that did have
these.  

 After some web searching, I found about the dag repository. I added the
following into /etc/yum.repos.d/dag.repo as stated at
http://dag.wieers.com/home-made/apt/FAQ.php :

[dag] 
name=Dag RPM Repository for Red Hat Enterprise Linux
baseurl=http://apt.sw.be/redhat/el$releasever/en/$basearch/dag 
gpgcheck=1 
enabled=1

  Now when I do a "yum list" I can find lots of the apps that I am
looking for. But when I try to install packages I get things like:

warning: rpmts_HdrFromFdno: V3 DSA signature: NOKEY, key ID 6b8d79e6


Public key for libquicktime-0.9.8-2.el4.rf.i586.rpm is not installed


 I can get installs to happen by changing the line in
/etc/yum.respon.d/dag.repo from one to zero on the gpgcheck line.

Questions:

1) Is dag a good repository to get me these apps that aren't part of the
stock CentOS repository file? If not, which one should I use? I don't
need bleeding edge (even two versions behind for an app would be fine).

2) What's up with the gpg failures? Should I be worried?

3) Finally, I'm trying to get xawtv to work. I ran "yum install xawtv"
and all seemed to go fine. It found a bunch of dependencies and
downloaded them from dag. Cool!  But when I try to run xawtv I get:

This is xawtv-3.94, running on Linux/i686 (2.6.9-34.EL)
load_codec_info_from_plugin: dlopen failed for
/usr/lib/libquicktime/lqt_ffmpeg.so:
/usr/lib/libquicktime/lqt_ffmpeg.so: undefined symbol: avcodec_init

 Searching for this error has been less than fruitful.

 I realize this message has several questions in it. If you have
opinions on ANY of the questions please feel free to respond.  Yum and
CentOS have me wanting to go back to Linux. If I can be taught how to
use yum to install things "correctly" I think I'll be very happy back
here. :-)

Thanks in advance.

- Damian




More information about the CentOS mailing list