[CentOS] small "$" issue with samba on centos 4x [dnk]

Tue May 2 14:56:36 UTC 2006
Lists <lists at littlebald.com>

On Mon, 1 May 2006, dnk wrote:

> Good day..... This is a slightly older issue for me. In the past I had tried 
> to install Samba on a centos 4.0 box, and the useradd tool on Centos 4 would 
> not add the "$" character to the usernames being created.
> I was wondering if anyone ran into this issue on the current 4.3
> I have another install  coming up and I would * really * prefer to use the 
> latest centos build.

I ran into this on 4.0, too.  It's fixed now.

For those interested in the details, here are some notes from
  `rpm -q --changelog shadow-utils` :

* Mon Mar 14 2005 Peter Vrabec <pvrabec at redhat.com>
- allow dollar sign at the end of group/user name (#150770) 2:4.0.3-42.RHEL4

* Wed Oct 27 2004 Adrian Havill <havill at redhat.com> 2:4.0.3-38
- conform to posix for user/group name input checking [def 3.426
   and 3.189] which is posix portable filename character set [3.276]
   while disallowing dash for first char as recommended, and disallow
   dollar sign