[CentOS] cdrecord issues

Wed May 3 14:22:01 UTC 2006
James Olin Oden <james.oden at gmail.com>

On 5/3/06, Shawn K. O'Shea <shawn at ll.mit.edu> wrote:
> Johnny Hughes wrote:
> >I just use K3B to do all my recording now with CentOS-4 ... GUI will be
> >the death of us all ... :)
> >
> >But I remember something about the 2.6 kernel and use of the ATAPI
> >target being required instead of the old IDE-SCSI method when using
> >cdrecord.
> >
> >I don't remember the particulars, but google might.
> >
> >
> >
> >
> This might relate to that. The IDE DVD burner in my machine (identified
> as 1,0,0 in -scanbus) doesn't work as dev=1,0,0, but *does* work as
> dev=ATA:1,0,0
> Hope that helps.

I recently had a simular issue, and could get farther when specifing
the transport (i.e. ATA, ATAPI), but it still would not work for me. 
Someone tried just specifying the device file, instead of the scsi ID
and that worked perfectly.  I don't know what changed in cdrecord
between RHEL 3 and RHEL 4, but just using the device file seems to be
the path that works (i.e. dev=/dev/scd0).