[CentOS] CentOS on Dell Inspiron 640m laptop

Patrick centos-list at puzzled.xs4all.nl
Wed Nov 1 12:01:52 UTC 2006


Just pitching in a "me too" and possible work around.

On Tue, 2006-10-31 at 22:43 -0600, Aleksandar Milivojevic wrote:
> Ben wrote:
> > I haven't got s2ram working. I think it has something to do with the
> > SATA hard drive...

Yup, got that too.

> Hmmm...  I'm having suspend-to-ram problems with Linux in general (2.4.x 
> and 2.6.x kernels) for a long time on my old laptop.  In my case it 
> sound like the (IDE) hard drive does not spin up after return from 
> suspend (actually, it sounds like the drive spins up, and than 
> immediately spins down).  Of course without hard drive working, the 
> things get frozen quite fast (as soon as a page or two needs to be 
> fetched from the drive).  Does your problem sounds something like that too?

Yes, suspend to ram works fine. Always has iirc. But resume never worked
out of the box. On resume the drive led flickers a bit and that's the
end of it. Black screen too. This is an Acer laptop by the way.

> Under Windows, all worked fine.  Interesting thing is that under Windows 
> I can hear the drive spin up, than spin down, and than spin up again. 
> I'm just speculating, but it might be that first spin up/down is 
> controlled by BIOS, and that Windows spins up the drive again.  While 
> the Linux (wrongly) expects that the BIOS spun up the drive.

In my limited understanding of this issue I think that Windows just
pokes the BIOS to poke/awake the drive such that the normal part of
resume that expects the drive to be there actually finds a drive that's
alive and responsive.

The workaround on my laptop is to boot with "noapic irqpoll". Resume
works if I specify that. Last time I tried it I got a message
in /var/log/messages that this is going to kill performance and the
little battery disappeared from my Gnome taskbar. Not a perfect solution
but maybe it works for you.

> One thing that I attempted was to rebuild centosplus kernel with 
> BIOS-independent suspend support enabled (or at least I hope that was 
> what the option was).  But it failed to compile.

I tried suspend2 kernels on FC a few months ago and that did not work


More information about the CentOS mailing list