[CentOS] Problems with yum/rpm and %pre scriptlet error 255

James B. Byrne byrnejb at harte-lyne.ca
Wed Nov 8 20:37:50 UTC 2006



I am running xen (2.6.16-xen3_86.1_rhel4.1) on top of a stock CentOS-4.4
installation.  I have not added any additional virtual machines however.

When trying to install (as root) acrobat reader 7 for Linux from the adobe
rpm (AdobeReader_enu.i386 7.0.8-1) I get the following errors:

error: %pre(AdobeReader_enu-7.0.8-1.i386) scriptlet failed, exit status 255
error:   install: %pre scriptlet failed (2), skipping AdobeReader_enu-7.0.8-1

This occurs whether I use yum or rpm directly to effect installation and
whether or not setenforce is 0 or 1 for SELinux.

I have looked for similar errors on google but none of the remedies that I
have found there seem to work (turning selinux off, using rpm
--replacepackages --replacefiles options).

Does anyone here have any ideas that they care to share regarding what is
likely the problem or how to fix it?

Sincerely,

--
James B. Byrne                mailto:ByrneJB at Harte-Lyne.ca
Harte & Lyne Limited          http://www.harte-lyne.ca
9 Brockley Drive              vox: +1 905 561 1241
Hamilton, Ontario             fax: +1 905 561 0757
Canada  L8E 3C3


-- 
James B. Byrne                mailto:ByrneJB at Harte-Lyne.ca
Harte & Lyne Limited          http://www.harte-lyne.ca
9 Brockley Drive              vox: +1 905 561 1241
Hamilton, Ontario             fax: +1 905 561 0757
Canada  L8E 3C3



More information about the CentOS mailing list