[CentOS] IPP2P RPM ( was: How to block Yahoo , MSN messanger and Kazza with IPTABLES)

Ralph Angenendt ra+centos at br-online.de
Thu Nov 9 11:05:33 UTC 2006

Indunil Jayasooriya wrote:
>    below are errors I got, my centos 4.4 kernel is
>    2.6.9-42.0.3.EL
>    [root at worldnet opt]# rpm -ivh ipp2p-0.8.0-6.el4.hrb.i686.rpm
>    warning: ipp2p-0.8.0-6.el4.hrb.i686.rpm: V3 DSA signature: NOKEY, key ID
>    3e6e97c3
>    error: Failed dependencies:
>            kmod-ipp2p = 0.8.0 is needed by ipp2p-0.8.0-6.el4.hrb.i686
>    then I tried to install kmod-ipp2p
>    then i got the below error,
>    [root at worldnet opt]# rpm -ivh
>    kmod-ipp2p-0.8.0- m
>    warning:  kmod-ipp2p-0.8.0-  V3 DSA
>    signature: NOKEY, key ID 3e6e97c3
>    error: Failed dependencies:
>            ipp2p is needed by kmod-ipp2p-0.8.0-

I see one problem here: the kmod-ipp2p you have is for the
2.6.9-42.0.2.EL kernel, while you have 2.6.9-42.0.3 (a rebuild of the
src.rpm against a newer kernel should fix that).

The second "problem" is a circular dependency between ipp2p and
kmod-ipp2p, which can be solved easily by installing both packages in
one run:

rpm -Uvh kmod-ipp2p ipp2p


Ralph Angenendt......ra at br-online.de | .."Text processing has made it possible
Bayerischer Rundfunk...80300 München | ....to right-justify any idea, even one
Programmbereich.Bayern 3, Jugend und | .which cannot be justified on any other
Multimedia.........Tl:089.5900.16023 | ..........grounds." -- J. Finnegan, USC
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.centos.org/pipermail/centos/attachments/20061109/e7ee92ea/attachment.sig>

More information about the CentOS mailing list