[CentOS] bacula rpm --rebuild on x86_64?

Gordon McLellan gordonthree at gmail.com
Thu Nov 9 15:46:15 UTC 2006


I tried to install the latest bacula last night, rebuilding from the
source rpm ... this is the command line I used, following the
instructions at bacula.org:

# rpmbuild --rebuild --define "build_centos4 1" \
--define "build_x86_64 1" --define "build_mysql4 1" bacula-1.39.26-1.src.rpm

but the rebuild fails, citing all sorts of dependencies being
required.   problem is, all the dependencies it mentions are for 386
and/or 32 bit, not x86_64.   when I try doing a yum install
somedependency, yum informs me it's already installed

so I tried to do a yum localinstall of the source rpm, and yum tries
to download the 32bit versions of the dependencies and then fails when
they conflict with the 64bit versions already installed.

here's the output of the rebuild:
[root at tachyon ~]# rpmbuild --rebuild --define "build_centos4 1"
--define "build_x86_64 1" --define "build_mysql4 1"
bacula-1.39.26-1.src.rpm
Installing bacula-1.39.26-1.src.rpm
warning: user sbarn does not exist - using root
warning: user sbarn does not exist - using root
warning: user sbarn does not exist - using root
warning: user sbarn does not exist - using root
warning: user sbarn does not exist - using root
warning: user sbarn does not exist - using root
error: Failed build dependencies:
        gcc-c++ is needed by bacula-1.39.26-1.x86_64
        autoconf is needed by bacula-1.39.26-1.x86_64
        atk-devel is needed by bacula-1.39.26-1.x86_64
        libstdc++-devel = 3.4.6-3 is needed by bacula-1.39.26-1.x86_64
        libxml2-devel is needed by bacula-1.39.26-1.x86_64
        pkgconfig is needed by bacula-1.39.26-1.x86_64
        pango-devel is needed by bacula-1.39.26-1.x86_64
        libtermcap-devel is needed by bacula-1.39.26-1.x86_64
        gtk2-devel >= 2.4 is needed by bacula-1.39.26-1.x86_64
        libgnomeui-devel >= 2.8 is needed by bacula-1.39.26-1.x86_64
        ORBit2-devel is needed by bacula-1.39.26-1.x86_64
        libart_lgpl-devel >= 2.3 is needed by bacula-1.39.26-1.x86_64
        libbonobo-devel >= 2.8 is needed by bacula-1.39.26-1.x86_64
        libbonoboui-devel >= 2.8 is needed by bacula-1.39.26-1.x86_64
        bonobo-activation-devel is needed by bacula-1.39.26-1.x86_64
        GConf2-devel is needed by bacula-1.39.26-1.x86_64
        freetype-devel is needed by bacula-1.39.26-1.x86_64

[root at tachyon ~]# uname -a
Linux tachyon 2.6.18.1 #3 Fri Oct 20 23:35:27 EDT 2006 x86_64 x86_64
x86_64 GNU/Linux

yes, I'm running a non standard kernel ... I needed to upgrade to get
better software raid support - if that is the problem, I can boot back
into the standard kernel, since I only needed 18.1 to use the "mdadm
--grow" feature to expand my raid5 array

any ideas?

thanks,
Gordon



More information about the CentOS mailing list