[CentOS] FW: [tclug-list] Drives Not Recognized on Dell Poweredge 1550 CentOs install

Phillip Crump pjcrump at bitstream.net
Sat Nov 11 16:22:47 UTC 2006




The raid card is an Adaptec 2100S.  

-----Original Message-----
From: Josh Paetzel [mailto:josh at tcbug.org]
Sent: Saturday, November 11, 2006 9:35 AM
To: tclug-list at mn-linux.org; pjcrump at bitstream.net
Subject: Re: [tclug-list] Drives Not Recognized on Dell Poweredge 1550
CentOs install


On Saturday 11 November 2006 01:20, Phillip Crump wrote:
> I have a new (used)Dell Poweredge 1550 server with 2 scsi drives
> (dual 1ghz w/ 2048MB) that I'm attempting to install CentOs 4 onto
> and am having problems getting the darn thing to recognize the hard
> drives. (it's worth noting that it's running RAID 0 and the RAID
> bios recognizes both drives as being in "optimal" state).  I start
> the
> installation process and all is going well until it autoprobes. All
> other hardware is found
> except for the hard drives. The install subsequently fails because
> there the drives can't be found.
>
> I have been googling my brain out over the last week and this seems
> to be an issue with installing linux
> on this particular server model. (surrounding the megaraid driver
> and have tried many of the
> things out there to no avail.
>
> To see what I have been trying checkout this mailing list entry:
> http://lists.centos.org/pipermail/centos/2005-August/010021.html
>
> Any advice that anyone can give is appreciated!
>
> P.S. I have tried to install Debian, Mandrake and FC6 to no avail.
>
>
> PJ

If memory serves there were a few different RAID controllers available 
for the 1550.  Since you don't mention which controller yours has 
it's only possible to offer suggestions.

One possibility is that there simply isn't a linux driver for it, in 
which case it isn't going to matter which distro you try to install 
on it.  It's just not going to work.

Another option that you may have is that some of the RAID controllers 
that Dell used (the PERC/3's come to mind) had the ability to emulate 
a plain SCSI controller.  This was generally togglable in the BIOS.  
If yours has this option it's possible that it will emulate something 
that there is a driver for.  I have actually run into this before 
with the PE2450s.  In SCSI mode the controller appeared as an adaptec 
78xx which had a driver, in RAID mode it was something completely 
different (what exactly it was escapes me at the moment).

-- 
Thanks,

Josh Paetzel





More information about the CentOS mailing list