[CentOS] HELP: CentOS box won't shutdown

Clive Gould clive at ce.bromley.ac.uk
Tue Oct 10 08:31:45 UTC 2006

Hi everyone

Thanks for the suggestions :-)

There was a problem with the Clamscan AV process that was taking 100% CPU

I killed the offending process, but the system would still not reboot.

On visting the server room we found the vle server terminal session frozen.

On rebooting the kvm switch in the server room the VLE server
automatically rebooted!

Presumably there was a running process preventing the reboot command from
taking effect and unfreezing the terminal session somehow freed things up.

The server is running fine again now :-)

Most strange...

Best wishes


> On 10/10/06, Clive Gould <clive at ce.bromley.ac.uk> wrote:
>> We have a mission critical Dell rackmount server.
>> I tried to reboot it via an ssh session and it just kept running!
>> The command I used was:
>> [root at vle tmp]# shutdown -r now
>> Broadcast message from root (pts/0) (Tue Oct 10 08:28:44 2006):
>> The system is going down for reboot NOW!
>> Looking at /var/log/messages it says:
>> Oct 10 08:28:44 vle shutdown: shutting down for system reboot
>> But the server just keeps on running!!!
> Check the running processes with either "ps -efl" or "ps auxww", look
> for references to shutdown/init and try to figure out what's going on.
> I'd guess there's an uninterruptible process running, init's trying to
> stop it but can't. You need to find it and try killing it, possibly a
> "kill -9" though be careful you know what it is you're killing.
> You could also try "init 6" or "reboot -f" to see if either of those
> will successfully restart your system.
> Will.
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

More information about the CentOS mailing list