[CentOS] USB multi-card reader working, finally took the time

Robert Moskowitz rgm at htt-consult.com
Tue Oct 17 04:26:17 UTC 2006


A thread on multi-cards 2 months ago, gave me a hint on how to get usb 
multi-card readers working:

Quoting "J.J. Garcia" <stigmatedbrain at gmail.com>:

"Have you tried putting it into /etc/modprobe.conf (options scsi_mod 
max_luns=32) and rebuilding initrd image after that?  That's the way I 
was doing it so far, and it always worked for me. "

So I then had to learn how to rebuild initrd image.  Turns out that is 
mkinitrd  (duh :-[ ).

So I added to my /etc/modprobe.conf:

options scsi_mod max_luns=8


Then:

mkinitrd -v --image-version ....

edited /boot/grub/grub.conf to use this new initrd, and now my MP3 
players with internal and external SD cards are working properly.

I am ASSuMing that once modprobe.conf is altered, as I get new kernels, 
the change will carry forward, and I will not have to do my own mkinitrd?

I base this on my recent update to 42.0.3 and a new initrd file.





More information about the CentOS mailing list