[CentOS] make 3.79.1 assertion failed error

Dag Wieers dag at wieers.com
Tue Oct 17 23:35:02 UTC 2006


Hi,

Sorry for cross-posting but I need to tap into my most helpful 
mailinglists for this problem. I have had assertion failed errors from 
make before and never understood what they were or where they came from.

But now that I have them consistently for ffmpeg and mplayer on everything 
smaller than FC2, which prevents me from updating both mplayer and ffmpeg 
(and I know lots of other applications have the same issue).

The exact error is:

	make: expand.c:489: allocated_variable_append: Assertion `current_variable_set_list->next != 0' failed.

By coincidence (called Google) I found this page:

	http://valgrind.org/docs/manual/faq.html#faq.make_dies

and it made the relation with make 3.79.1 pretty clear. (fc1, el3, rh9, 
rh7 and el2 all use make 3.79.1)

I was wondering if anyone knows of a better solution than explained in 
the valgrind FAQ, or better than upgrading make.

Once upon a time mplayer built without this assertion, other applications 
as well. So is this caused by a more recent configure/autotools used by 
the developers ? Some way to prevent this ?

Anyone ? :)

Kind regards,
--   dag wieers,  dag at wieers.com,  http://dag.wieers.com/   --
[all I want is a warm bed and a kind word and unlimited power]



More information about the CentOS mailing list