[CentOS] 4.4 upgrade problems

David Hrbáč hrbac.conf at seznam.cz
Tue Sep 5 13:07:02 UTC 2006

Johnny Hughes napsal(a):
> 1.  You need to install python-sqlite before sqlite (or at nearly the
> same time).
> To accomplish this you can do this:
> yum update python-sqlite sqlite

I'd add, please do not update sqlite alone. Updating sqlite prior
python-sqlite will end with yum not working completely. Yum will start
and finally eat all available memory during repodata reading. OS may hang.

Maybe dev team could release update version of yum, sqlite, and
python-sqlite with changed dependecy in specs? So 'yum update yum' will
lead to update all the three packages.

More information about the CentOS mailing list