[CentOS] Mdadm Dependancies - Centos 4.3

Dan Pritts danno at internet2.edu
Fri Sep 8 22:32:11 UTC 2006

> >I have a mail server (Qmail) and just tried to install mdadm to monitor
> >the raid arrays via Yum and it tried to install exim. Is this correct? I
> >guess that it is looking for an MTA so why is it not finding Qmail (linked
> >to /usr/lib/sendmail). One possibility is that I used yum to actually
> >uninstall sendmail, but installed qmail from source as it needed patching.
> It won't find qmail because qmail isn't in the rpm database, so yes...
> mdadm is doing the right thing by trying to install a mailer. It's
> linked as a dependency to notify admins if an array has issues.

> >Any way out of this apart from installing mdadm from an rpm with no deps/

a bit late on the reply, but to solve this kind of thing you can build your
own RPM that does not contain any files but does resolve the dependency.

I've attached a spec file that i did for this that satisfies the dependency
"java".  You should be able to modify it for your needs.

Dan Pritts, System Administrator
office: +1-734-352-4953 | mobile: +1-734-834-7224
-------------- next part --------------
%define name fakejava
%define version 1.4.2
%define release 1

Vendor: danno
Packager: danno
Distribution: dannoOS
URL: http://www.internet2.edu

BuildArchitectures: noarch

Summary: A fake package so that rpm thinks we have "java"
Name: %{name}
Version: %{version}
Release: %{release}
Group: internet2
Source: %{name}-%{version}.tar.gz
BuildRoot: /tmp/%{name}-%{version}
License: GPL

Provides: java = %{version}
Provides: jre = %{version}
Provides: jaas = %{version}
Provides: jsse = %{version}
Provides: j2sdk = %{version}
Provides: j2re = %{version}

A fake package so that rpm thinks we have "java"





#/bin/rm fakejava-install-a-file-for-me







More information about the CentOS mailing list