[CentOS] 4.4 kickstart issues

Steve Finley finley at privacynetworks.com
Thu Sep 21 23:43:36 UTC 2006


Thanks for responding.  My bad - I have a typo in my original post.  I show


..it actually is initscripts-7-93.25.EL-1.centos4

As you point out:
 "7.93.25.EL is >= 7.93.14.EL"
and I expected this to be fine too.  I guess I misinterpreted the output 
from pkgorder:

warning: removing initscripts-7.93.25.EL-1.centos4 "Requires: 
/sbin/nash" from tsort relations.
warning:     initscripts-7.93.25.EL-1.centos4         Requires: /sbin/nash
warning:     mkinitrd-                       PreReq: dev
warning:     udev-039-10.15.EL4                       PreReq: hotplug
warning: removing hotplug-2004_04_01-7.7 "Requires: initscripts >= 
7.93.14.EL" from tsort relations.
warning:     hotplug-2004_04_01-7.7                   Requires: 
initscripts >= 7.93.14.EL

If I grab disc1 from the iso distribution and perform a linux rescue my 
failed install, I see
this is the install.log:

Installing initscripts-7.93.25.EL-1.centos4.i386.
/usr/sbin/groupadd: error while loading shared libraries: libaudit.so.0: 
cannot open shared object file: No such file or directory
error: %pre(initscripts-7.93.25.EL-1.centos4.i386) scriptlet failed, 
exit status 127
error:   install: %pre scriptlet failed (2), skipping 

I have other error messages in the install.log as well.  I have had 
pleanty of success with
FC3 kickstarts.  I made the (apparently incorrect) assumption that the 
CentOS kickstart would
be exactly the same.  Perhaps you could point me to a document?

Thanks again

Steve Finley

Johnny Hughes wrote:
> On Thu, 2006-09-21 at 12:10 -0600, Steve Finley wrote:
>> Greetings all,
>> I'm trying to create a CentOS 4.4 kickstart CD (not a network install), 
>> duplicating what
>> I've done for Fedora Core 3.
>> I am having a cirular dependency for initscripts, which causes 
>> initscripts not to be installed
>> (no /etc/inittab when the boot gets to INIT)
>> The cascade is:
>> initscripts-7.39.25.EL-1.centos4 requires /sbin/nash
>> /sbin/nash is in mkinitrd-
>> mkinitrd- requires dev
>> dev appears to be in udev-039-10.15.EL4
>> udev-039-10.15.EL4 requires hotplug
>> hotplug requires initscripts-7.93.14.EL
>> I'm guessing that the hotplug spec file is wrong.  I can build my own 
>> version and continue finding
>> conflicts (like the circular dependency between cracker and 
>> cracker-dict, for example), but my
>> real question is, how is your iso distribution able to install with this 
>> initscripts conflict?
> There is no conflict .... at least not a version conflict.  I do CD/DVD,
> http and NFS kick starts all the time.
> ------------------------------------------
> [johnny at myth ~]$ rpm -q --requires hotplug | grep initscripts
> initscripts >= 7.93.14.EL
> The above clearly says >= ... 7.93.25.EL is >= 7.93.14.EL, so that
> dependency is met.  Not sure why your hotplug is set to "initscripts =
> 7.93.14.EL", or at least why it is being interpreted that way by
> whatever process you are trying to use.
> ------------------------------------------
> Thanks,
> Johnny Hughes
> ------------------------------------------------------------------------
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

More information about the CentOS mailing list