[CentOS] Jpackage tomcat55-common-lib requires eclipse-ecj >= 0:3.1.1

Matt Hyclak hyclak at math.ohiou.edu
Wed Sep 27 13:25:14 UTC 2006

On Wed, Sep 27, 2006 at 01:09:49PM +0100, Will McDonald enlightened us:
> Guys,
> I'm running into a dependecy issue running through the process of
> building a system for Openbravo. My test system's running CentOS 4.4,
> i386.
> Openbravo requires...
> - Jakarta-Tomcat version 5.5. It can be downloaded from
> http://tomcat.apache.org/
> - Java (TM) 2 Platform Standard Edition 5.0. It can be downloaded from
> http://java.sun.com/j2se/1.5.0/download.jsp
> - Oracle(r) 10g database release 2. It can be downloaded from
> http://www.oracle.com
> - Apache-ant 1.6. It can be downloaded from http://ant.apache.org/
> So far (see attached text file for rough documentation of build
> sequence) I've built Java and JTA successfully. When I try to install
> tomcat55 it results in...
> "Error: Missing Dependency: eclipse-ecj >= 0:3.1.1 is needed by
> package tomcat55-common-lib"
> Jpackage 1.6 only has eclipse-3.0.2 as far as I can see. So, my
> question, is there a preferred or authoratative source for
> packaging/or a prepackaged Eclipse that'll fulfil my requirements?
> I've searched around and found mention of Jason Corley 's SRPMs
> http://www.zarb.org/~jasonc/repo/ from
> https://www.zarb.org/pipermail/jpackage-discuss/2006-June/010098.html,
> I'll have a play with those now.
> Do I need to switch to 1.7 to fulfil these requirements? Any
> suggestions or best-practices greatfully received.

You might also look at the thread here:


It looks like you can bootstrap the process by installing a pre-built
eclipse-ecj, even if it's not for your specific distro, since it is pure
java files.


Matt Hyclak
Department of Mathematics 
Department of Social Work
Ohio University
(740) 593-1263

More information about the CentOS mailing list