[CentOS] Re: yum libxml2mod

Scott Silva ssilva at sgvwater.com
Wed Sep 27 15:39:20 UTC 2006

Jesus Bernardo Ruiz Flores spake the following on 9/26/2006 6:31 PM:
> I have a problem using yum. it gives me the following error
> [root at mail1 src]# yum update yum
> There was a problem importing one of the Python modules
> required to run yum. The error leading to this problem was:
>   /usr/lib/python2.3/site-packages/libxml2mod.so: undefined symbol:
> xmlNewDocPI
> Please install a package which provides this module, or
> verify that the module is installed correctly.
> It's possible that the above module doesn't match the
> current version of Python, which is:
> 2.3.4 (#1, Mar 10 2006, 06:12:09)
> [GCC 3.4.5 20051201 (Red Hat 3.4.5-2)]
> If you cannot solve this problem yourself, please go to
> the yum faq at:
>  http://wiki.linux.duke.edu/YumFaq
> I have looked in Internet and others forums but i couldn't find any
> answer on how to fix this error.
It looks as if you might need to download the current rpm-python and maybe
rpm-libs and do an rpm -Uvh with them.
Run a "rpm -qa|grep rpm" and post it to make sure.


MailScanner is like deodorant...
You hope everybody uses it, and
you notice quickly if they don't!!!!

More information about the CentOS mailing list