[CentOS] Re: Installing CentOS 2.1 on ICH7R controller

Scott Silva ssilva at sgvwater.com
Thu Sep 28 23:51:05 UTC 2006

Aleksandar Milivojevic spake the following on 9/28/2006 11:53 AM:
> Quoting rado <rado at rivers-bend.com>:
>> Alexandar, when you get your system up, if you run dmesg...does it show
>> where it's picking the drive up?
> Well, it's in the PATA emulation mode, so it picks it up as soon as
> kernel probes for IDE drives (no additional modules required).
> Anyhow, I managed to get the initrd image fixed.  However, the system
> hangs at random places when accessing the drives (after all file systems
> are mounted).  So I guess CentOS 2.1 and ICH7R are not ment to be (at
> least on SuperMicro PDSMi motherboard).  It's probably some small bug in
> IDE driver -- SATA configured in PATA emulation mode should just work
> (worst case is it would work in PIO mode).  Unless Intel screwed up
> something bad in the chipset.
> On the other hand, CentOS 3.8 runs fine on the same hardware with SATA
> in native mode (with AHCI disabled) so it might be an option too. 
> However, it has some similar symptoms to CentOS 2.1 if I force it to
> PATA compatibility mode.
> As a side note, CentOS 4.4 runs with AHCI enabled, and also seems to
> show some problems if I force system to PATA compatibility mode.  Hmmm...
> --NOTICE: If you are not intended recipient, you are hereby notified
> that by reading this message you agreed not to disturb frogs during
> mating season.  For more info, visit http://www.8-P.ca/
There must be some pressing issues to go to all the trouble of installing 2.1
on new hardware. It is probably closed and in maintenance only state.


MailScanner is like deodorant...
You hope everybody uses it, and
you notice quickly if they don't!!!!

More information about the CentOS mailing list