[CentOS] Strange screen-blanking problem

Wed Sep 6 23:23:10 UTC 2006
Bart Schaefer <barton.schaefer at gmail.com>

My desktop at work is CentOS 3.8, using the motherboard's onboard
Intel 865 (82865G) graphics controller.  Most of the day today I've
been having sporadic instances where the screen simply goes black for
about 2 seconds.  It has nothing to do with whether I'm using the
mouse or keyboard (or not) and the delay before it comes back on is
not correlated to whether I *continue* to use the mouse or keyboard.

This has happened a few times before.  Sometimes the system is up for
weeks at a time without showing any sign of this, sometimes it
re-appears every few days. I've tried shutting down and restarting
X11, but that doesn't get rid of it -- it seems only a full reboot
will do so.  And the longer I wait to reboot, the more often it

It doesn't seem to be related to the clock or to ntp (I've seen ntp
clock syncs trip the screen saver in X11 before), I've tried shutting
down ntpd without any change in the behavior and the system clock is
not drifting from other machines on the LAN either way.  There's
nothing in the log files indicating any activity that might be

Anyone have a clue where I might begin looking?  Having to reboot a
linux machine with only 6 days of uptime galls me.