[CentOS] Yum upgrade to 4.4 problem

Fri Sep 1 01:22:43 UTC 2006
Matthew Miller <mattdm at mattdm.org>

On Fri, Sep 01, 2006 at 01:32:52AM +0100, Karanbir Singh wrote:
> >> Should not sqlite depend on python-sqlite if python-sqlite needs to be 
> >> updated first?
> > Nope, because sqlite will work fine without the python bindings.
> python-sqlite-1.1.7 with a requires for the right, newer version of
> sqlite should resolve this issue..

How so? The problem isn't that python-sqlite 1.1.7 requires sqlite 3.3.x --
it's that sqlite 3.3.x conflicts with python-sqlite 1.1.6.

It doesn't matter if you make python-sqlite 1.1.7 require the new version of
sqlite -- in fact, that'll likely make it worse, since it'll make sqlite get
updated first, which is the wrong way around.

Matthew Miller           mattdm at mattdm.org          <http://mattdm.org/>
Boston University Linux      ------>              <http://linux.bu.edu/>