[CentOS] Radeon 9000 breaks with CentOS 4.4

Thu Sep 7 12:48:03 UTC 2006
William L. Maltby <CentOS4Bill at triad.rr.com>

On Wed, 2006-09-06 at 23:07 -0500, Barry Brimer wrote:
> Dell Inspiron 600M w/ Radeon 9000 card.  This worked with CentOS 4.3, also 
> works with Knoppix 4.0.2.  Graphical installation succeeds, but upon 
> reboot, and all subsequent rebbots, graphical mode does not work, the 
> screen becomes black.  In addition to the 2.6.9-42 kernel, we have also 
> tried the 2.6.9-42.0.2 kernel.  Same problem exists on both kernel. 
> Running system-config-display --reconfig exits with the error "fatal IO 
> error 104" Connection reset by peer.
> Any ideas would be greatly appreciated.

If you <Ctl-Alt-F1> can you get a login prompt? If so, look
at /var/log/dmesg, /var/log/messages and /var/Xorg.0.log (IIRC).

There may be some clues in there. Comparing the Xorg log to a previous
version might yield a clue.

An lsmod to see if a radeon module has been loaded? Keep an eye out for
radeonfb as well. DRI is supposed to be unstable with radeons (although
I run it NP). Keep an eye out for that and make sure the Xorg log shows
it is disables.

Go to /etc/X11 and see if an Xorg.conf exists. If so, look at it and
sett any resolutions to lowest/plain vanilla to start with.

> Thanks,
> Barry
> <snip sig stuff>

I'm a novice at this stuff, but I have the time to reply.