[CentOS] Installing CentOS 2.1 on ICH7R controller

Thu Sep 28 16:21:20 UTC 2006
rado <rado at rivers-bend.com>

On Thu, 2006-09-28 at 11:16 -0500, Aleksandar Milivojevic wrote:
> I'm trying to install CentOS 2.1 on SATA drive that lives on ICH7R  
> controller.  I have the controller setup in BIOS to "compatibility"  
> mode, which means it should look just like regular IDE controller to  
> the OS.  In this mode, ide0 and ide1 are PATA controllers, and 4 SATA  
> ports are mapped to ide2 and ide3.
> If I boot from the 2.1 installation CD, all the drives are detected  
> (CD-ROM as hda, and four SATA drives as hde, hdf, hdg, and hdh, just  
> as expecte per above mappings).  It detect IRQ for ide2/3 right away,  
> and says it will probe for IRQ for ide0 later.  Well, it hangs just  
> after it probes and detects IRQ for ide0.  I've tried all bunch of  
> "standard" kernel options (turnning off DMA, disabling ACPI, and so  
> forth), none of which helped.
> If I install the OS on some other box (with older SATA controller),  
> update the kernel to 2.4.9-e.70, move the disk to the new box, the  
> kernel boots just fine (however, the initrd image points to the wrong  
> root device -- and I can't really boot into rescue to fix it, since  
> kernel on install CD will hang).  Hence I attempted to rebuild 2.1  
> install CD with 2.4.9-e.70 kernel (which I haven't managed to do yet).
> I also attempted to use CentOS 3.8 CD in rescue mode.  However,  
> regardless of my BIOS settings, it loads ata_piix drivers, and uses  
> the controller in SATA mode, which isn't really what I want (mkinitrd  
> trying to be too smart, but I have couple of tricks to try yet).  I'm  
> currently attempting to force it into PATA emulation mode by supplying  
> "ide2=io1,io2,irq and ide3=io1,io2,irq" parameters, and it is going  
> *very* slow and constantly complaining about lost interrupts.
> Anyhow, if anybody has some advice with getting this 2.1 install  
> going, it would be very appreciated.
Alexandar, when you get your system up, if you run dmesg...does it show
where it's picking the drive up?

reason I asked...I am presently setting up an external hd thru
usb...kudsu never asked about it but dmesg said it sees the drive and
calls it sda...I'm trying to incorporate it in my raid arrays and I am
so close but not there yet...got the drive partitioned exactly like the
other 2 internal ides ...when I run cat /proc/mdstat all the arrays are
showing w/it but you know when you add a drive mdadm /dev/md0 --
add /dev/sda1 etc for all the partitions...then run
cat /proc/mdstat...you should see the drive populating but it
doesn't...gotta do little more reading.