[CentOS] Re: network config files in centos 5 changing

Thu Apr 26 19:34:06 UTC 2007
Walt Reed <wreed at vinq.com>

On Thu, Apr 26, 2007 at 12:04:46PM -0700, Scott Silva said:
> Jerry Geis spake the following on 4/26/2007 11:53 AM:
> > 
> >> have had same problems with my asus m2npv-vm board  (onboard
> >> forcedepth nic) the first days with the board under fedora 6 - would
> >> say no big diff's to centos-
> > I tried loading centos 4 but it does not even recognize the forcedeth
> > device at all.
> > even manually loading.
> > 
> > I'm at a loss. I have a script file that runs and sets things up the way
> > I want after boot up. Not pretty - but I guess it works.
> > 
> > Jerry
> This appears to be a bug in the forcedeth driver and the chipset. The driver
> seems to pull the current MAC address from a register, and writes it back
> differently. The systems with the trouble must allow this write to take place,
> and it changes the MAC address for the next boot.
> I think if you add a HWADDR: xx:xx:xx:xx:xx:xx  command to the ifcfg script,
> it might stick. You will have to find your real MAC address on your own, but
> it might be on a sticker somewhere on the board, or in a service tag on the
> equipment.

I would go farther and suggest just installing a real Intel ethernet
card and be done with it if at all possible.

I also have an asus board with the nvidia / realtek / forthdeth driver
chip and have had nothing but problems no matter what distro I run.

It's not worth messing with a device that the manufacturer supports so
poorly. I'm going to make sure that any motherboard I buy in the future
does NOT have that crappy ethernet chipset in it.