[CentOS] recording sound: how 2 control recording level?

Sat Apr 28 16:01:39 UTC 2007
fredex <fredex at fcshome.stoneham.ma.us>

On Sat, Apr 28, 2007 at 08:40:56AM -0400, Tim Wunder wrote:
> On Saturday 28 April 2007 6:58:47 am fredex wrote:
> > Hi gang!
> >
> > I'm trying to record (to .wav files) sound coming in on the line input
> > of my sound card (in this case, output of a tape deck).
> >
> > For LISTENING purposes, I can control the level with the Gnome Mixer.
> >
> > However, the RECORDING level is not affected by the mixer. As a result,
> > the recorded audio is badly clipped and horribly distorted.
> >
> > I don't understand enough about how this stuff works to have a clue
> > how to troubleshoot this problem.
> >
> > Can someone offer helpful advice?
> >
> Dunno about the gnome mixer, but kmix has input and output settings. What are 
> you using to make the recording? Audacity seems to have a slider for input 
> volume. 

I've tried Audacity and rec (from the sox package) and ecasound and 2
or 3 other things I've run into while Googling.

I have to admit that yes, Audacity does have a record level slider. And
it is the single app I've tried in which I CAN control the record level.
But even then, the recorded sound is slightly clipped sounding (though much
less bad) when played back. 

Note that the sound straight from the tape deck, when fed into the computer
and played through the speakers attached to the sound card, is fine (or as
close to fine as one can tell given the cheap speakers I have at the moment),
but when recorded then played back, even the recording from Audacity is
notably degraded.

Recording with Audacity seems sluggish--it updates the display (the waveform
display) in clumps rather than smoothly. When played back, in addition to 
the muddiness/distortion, there are occasional little defects where it sounds
as if some samples were lost. I'm guessing that all the graphical stuff
going on is making the system sufficiently busy that it loses blobs of
data during recording, which is why I was trying non-GUI recording tools.
All of them seem to want to record only with the record volume turned all
the way up. Viewing any of those recordings in Audacity shows that ALL the
sound is clipped, not just little bits of it, as with Audacity's recordings.

I'm running Centos 4.4 on an Athlon XP 2600+ with a gig of RAM, so it 
should have adequate horsepower. I did do some recording several years
ago on a K6-2/350 and didn't have these problems, and this machine has
LOTS more ponies under the hood than did that one.

ecasound comes with a tool named "ecasignalview" which shows the number of
clipped samples. Since I can't figure out how to adjust the input levels
to ecasound, it says basically that all samples are clipped.

I am using the built-in (AC-97) audio hardware, so it's surely not really
high-quality stuff, but still, it ought to be possible to do better than 
I have so far been able to do.

the Gnome mixer allows one to select a given input channel to be the one
being recorded, and presumably the slider for that channel is supposed to
control the recording level. But in fact all these programs, Audacity
included, will record regardless of the setting of the "rec" checkbox,
and the slider for the "line" input (which is where the tape deck comes
in) controls the audio volume I hear but has no effect on the record

I'm wondering if I should change my desktop to KDE and try with its sound
tools. I suppose it couldn't harm anything to try.

Suggestions welcome!
> Sorry I can't be more helpful, my stereo is not connected to my computer at 
> the moment. :(
> Tim

> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

---- Fred Smith -- fredex at fcshome.stoneham.ma.us -----------------------------
                        The Lord is like a strong tower. 
             Those who do what is right can run to him for safety.
--------------------------- Proverbs 18:10 (niv) -----------------------------
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.centos.org/pipermail/centos/attachments/20070428/ecbcf10b/attachment-0005.sig>