[CentOS] CentOS4 and older megaraid - SOLVED

Sun Jan 21 00:56:48 UTC 2007
David Booth <md at goulburn.net.au>

Here is my proposed recipe Part 2. Not tried.
I'll post results.
(unless anyone (Craig?) can spot a problem before I try)

# On the SCSI system, boot normally and get to 'no suitable disk'
rmmod megaraid_mbox
rmmod megaraid_mm
# insert the floppy with the 586 megamedia.ko
mount /media/floppy
insmod /media/floppy/megaraid.ko
# from tuxytyrvy:
# Verify that the module loaded
# see if megaraid is listed
# Verify that your RAID array was found
# see the output from the module load
# switch back to the normal install screen
#Since you've manually loaded the driver from the command prompt
# ignore the instructions to pick a driver. Continue the install.
# After all packages are installed and the system prompts you to reboot:
# Because the megaraid driver was installed manually the installer will
# not build a proper initrd.
# Fix this before the reboot right now with the following steps:
# switch from the GUI to a bash prompt
# look for the PATH to sysimage - ????
# may not be '/mnt' as documented by Craig
# Unmount floppy with 586 version of megaraid.ko and
# insert and mount the 686 one!
umount /media/floppy
# Insert floppy with 686 version of megaraid.ko
mount /media/floppy
# Copy the megaraid.ko module with the command
cp /media/floppy/megaraid.ko 
# set your root to your newly installed system image
chroot /PATH/sysimage
vi /etc/modprobe.conf
# make the line with
'alias scsi_hostadapter' say
'alias scsi_hostadapter megaraid'
# Save the file.
#Switch to the /boot directory
cd /boot
#Create new initrd file
mkinitrd initrd-2.6.9-42.EL.img.megaraid 2.6.9-42.EL
#Copy the new initrd over old initrd
cp initrd-2.6.9-42.EL.img.megaraid initrd-2.6.42-EL.img
#Exit chroot environment
# Switch back to the GUI installer
Alt-F7 and press Finish
David Booth