[CentOS] problem with CUPS

Thu Jan 25 08:26:27 UTC 2007
Rajeev R Veedu <rajeev at cracknell.com>

Solved. I have added the administrator as Printer admin and it fixed the








From: centos-bounces at centos.org [mailto:centos-bounces at centos.org] On Behalf
Of Rajeev R Veedu
Sent: Thursday, January 25, 2007 9:07 AM
To: 'CentOS mailing list'
Subject: [CentOS] problem with CUPS


I have made a CUPS print server and unable to load printer driver nor able
to install the printer on the windows machine.  The error I am getting is as
below: -

"Windows can not locate suitable printer driver. Contact your


I can print test page from the cups panel and the printer works fine. 


I tried to upload the driver through windows machine by right clicking the
properties saying no and clicking advance property tab, the new driver tab
is not highlighted.


Is it anything related to permission problem? I am using Centos 4.3 + samba
3.0.22.  Please find below my SMB.conf file and would really appreciate if
some one could tell me where I am going wrong!







        load printers = yes

        passwd chat debug = Yes

        idmap gid = 10000-20000

        admin users = root

        host msdfs = Yes

        wins server =

        null passwords = Yes

        domain master = No

        winbind use default domain = Yes

        public = yes

        passwd program = /etc/passwd %u

        template shell = /bin/bash

        lock directory = /tmp/samba

        dns proxy = No

        netbios name = PrintSrv

        printing = cups

        writeable = yes

        server string = Print Server

        printing = cups

        writeable = yes

        server string = Print Server

        idmap uid = 10000-20000

        password server =

        winbind nested groups = Yes

        unix password sync = Yes

        local master = No

        workgroup = DOMAIN

        os level = 0

        update encrypted = Yes

        printcap name = cups

        security = DOMAIN

        preferred master = No

        winbind separator = /

        winbind cache time = 10



        comment = Data-01

        path = /Data

        create mask = 0777

        directory mask = 0777

        guest ok = Yes



        comment = Home Directories

        valid users = %S

        public = no

        writable = yes

        printable = no

        create mask = 0640

        directory mask = 0755

        browsable = no


        comment  = All Printers

        browseable = yes

        printable = yes

        writeable = yes

        path = /var/tmp

        guest ok = yes

        print command = lpr -r -P'%p' -J'%j' -U'%U' %s



        comment =       Printer Drivers

        path    =       /var/lib/samba/drivers/

        create mask =   0664

        directory mask = 0775

        guest ok =      yes

       write list = rvrajeev


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos/attachments/20070125/7aeab58b/attachment-0005.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.jpg
Type: image/jpeg
Size: 11801 bytes
Desc: not available
URL: <http://lists.centos.org/pipermail/centos/attachments/20070125/7aeab58b/attachment-0005.jpg>