[CentOS] Java headaches

Tue Jan 30 15:47:33 UTC 2007
Robert Moskowitz <rgm at htt-consult.com>

Probably solved well enough,,,

Robert Moskowitz wrote:
> Well, almost there...
> Black Hand wrote:
>> On Tuesday 30 January 2007, Robert Moskowitz wrote:
>>> Installing Freemind.  It needs Java JRE.
>>> So after lots of pain, and reading past messages, I got
>>> jre-1_5_0_09-linux-i586.rpm from sun and installed it.
>>> Then I tried to follow Jim Perrin's recommendation to install from
>>> jpackage.org the java-1.5.0-sum-compat.rpm.  Thing is it is complaining
>>> about no JDK (not JRE!)
>>> yum install java-1.5.0-sun-compat  (have jpackage.org repo in 
>>> yum.repo.d)
>> .... <snip> .....
>>> OK.  What is broken here?
>> java-1.5.0-sun-compat works ONLY with the jdk, not the jre
>> i sugest to u to install the jdk, the jre is a subset of the full 
>> jdk, if your app need jre, then can work with the jdk too.
> OK.  I removed jre and installed jdk.  This allowed me to install the 
> java-sun-compat from jpackage.org, but now....
> java -version
> gets command not found.  I THINK in part this might be due to the 
> Alternatives commands I entered?  I HAVE NOT been able to trace 
> through all the links.  It seems to be a mess!
> And of course, although I finally got freemind installed (all sorts of 
> things needed from jpackage for that), it won't run without finding java.
I just deleted the broken link to java in /etc/alternatives, and made a 
new one.  Now Freemind is running.

I still have to see about getting java plugged into Firefox, I think.