[CentOS] First install No Sound

John Bowden j-alan at btconnect.com
Fri Jul 6 20:02:14 UTC 2007

On Friday 06 July 2007 17:49:13 Lorenzo wrote:
> John Bowden ha scritto:
> >> I have a similar board from Asrock which has apparently the same onboard
> >> audio card; on my FC5 install the audio module used is snd-hda-intel and
> >> the sound works... the relevant section in /etc/modules.conf is:
> >>
> >> alias snd-card-0 snd-hda-intel
> >> options snd-card-0 index=0
> >> options snd-hda-intel index=0
> >> remove snd-hda-intel { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ;
> >> }; /sbin/modprobe -r --ignore-remove snd-hda-intel
> >
> > It would seem that I do not have a "modules.conf in /ect/. I have opened
> > konqueror in super user mode and done a search starting from / and the
> > only matching file I can find is in
> > file:///usr/share/doc/kernel-doc-2.6.18/Documentation/video4linux/bttv/Mo
> >dules.conf. I do have a modeprob.conf in /ect and it does have some sound
> > entries in it. I can post the contents if needed.
> Sorry, that was a typo from me... the right file is modprobe.conf
> Before editing the file try with modprobe snd-hda-intel if it works
> --
> bye
> Lorenzo
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

Ok tried the modprobe snd-hda-intel command I got no error messages, but no 
sound. I also tried copying and pasting your sound section into my 
modprobe.conf file and rebooted. I watched the boot process and it is 
complaining about line 8 ( /sbin/modprobe -r --ignore-remove snd-hda-intel). 
Still no sound. Do I have to do a reboot when tinkering with the 
modprobe.conf file or is there a command to reload it?

Guy Fawkes, the only man to enter the house's of Parliament
with honest intentions, (he was going to blow them up!)
Registered Linux user number 414240

More information about the CentOS mailing list