[CentOS] Centos 5 yum update needs gpg key import

Karanbir Singh mail-lists at karan.org
Wed Jul 11 22:56:36 UTC 2007

hi Scott,

Scott Ehrlich wrote:
> I just performed a fresh install of 64-bit Centos 5 on a system, booted 
> fine, then performed a yum update, or at least tried to.  Files 
> downloaded, and were about to install, when it complained that the gpg 
> keys could not be found.

I would be slightly concerned about this - your centos install isnt a standard 
install - which should cause some alarm and maybe point at potential compromised 

> I ran into this about a month ago and found a web page showing the path 
> locally to where the keys live, and providing rpm --import /to/the/path.

Mechanisms for handling the key are built into yum, the fact that your system 
didnt come up with that would be further cause for concern.

did you sha1sum check the iso's ? did you run the media check on the install media ?

Karanbir Singh : http://www.karan.org/ : 2522219 at icq

More information about the CentOS mailing list