[CentOS] Newbie ADSL configuration, ppp0 can't activate & config not found

mailing-lists at computer2.com mailing-lists at computer2.com
Sat Jul 14 01:55:55 UTC 2007

I am frustrated. This is a dual boot box, Win XP (Spanish) and CentOS 4.4.
The phone company man came today and installed ADSL to the WinXP side and
that works fine. I can't get the box online, while in CentOS 4.4. The ADSL
router has a fixed IP address ( and he configured it to get
the IP from the ISP via DHCP and get the DNS servers automatically. When I
try that on CentOS (which is what I use 99% of the time), it doesn't
connect. In the Network Configuration for eth0, things seem OK, but the
configuration for xDSL, ppp0, probably needs something I do not have in it
and it won't activate. Questions: (a) should I have network configurations
for both eth0 and ppp0? I've tried it with both and only with ppp0. (b) is
there a possibility that the NIC, which is integrated onto the motherboard
and has always worked fine on our home LAN, as eth0, won't work properly
as ppp0? If so, should I disable it and install a NIC in the box? I've
looked in the RHEL Step by Step Guide for RHEL 4 and Systems
Administrators Guides, but they don't seem to cover this issue. Any links
to a step by step how to, to do something I believe is simple, but, where
I'm missing something, will be greatly appreciated! TIA, Lanny

More information about the CentOS mailing list