[CentOS] yum through a squid proxy

Dave dmehler26 at woh.rr.com
Thu Jul 19 09:23:03 UTC 2007

    I've got a centos5 box that is now behind a what was transparent squid 
proxy. The proxy now has it's own dedicated ip and uses proxy basic 
authentication. I've got a firewall that redirects all outgoing port 80 
traffic to that ip so anyone wishing access goes proxied. The problem is yum 
on my centos5 can't retrieve the .xml files for the various yum 
repositories. In the squid access.log on the router i'm seeing invalid 
request method. This means that the box isn't yet talking proxy and is still 
trying to go through direct. To my yum.conf file i added lines similar to 

# The proxy server - proxy server:port number
# The account details for yum connections

I tried port 80 on that proxy line with the same results. Telneting to that 
ip/port works fine, iptables isn't blocking it. On the firewall i added the 
yum-user to the password file and used squid's ncsa_auth program to confirm 
the username/password combination, output was a simple "ok". On the centos5 
box i did a service network restart, which didn't work, yum update gave me 
the same error.
    Any suggestions welcome.

More information about the CentOS mailing list