[CentOS] Re: possible corrupt rpm database

Axel Thimm Axel.Thimm at ATrpms.net
Tue Jul 24 14:02:59 UTC 2007

On Mon, Jul 23, 2007 at 04:48:32PM -0600, Grant McChesney wrote:
> On 7/23/07, Dave <dmehler26 at woh.rr.com> wrote:
> >
> >Hello,
> >    I've got a centos5 box that at least has a dependency issue or a
> >corrupt
> >rpm database. I am open to suggestions as to how to proceed. I have added
> >some extra repositories to my yum configuration, centosplus, rpmforge,
> >atrpms, and the kbs repos. I haven't been having issues with installs or
> >upgrades until today when i ran a yum update, and got a missing dependency
> >error for zaptel, a perl dependency. I've tried doing a yum install for
> >the
> >package, but no success. The error is below and i am open to suggestions.
> >Thanks.
> >Dave.
> >
> >#yum update
> >Loading "installonlyn" plugin
> >Setting up Update Process
> >Setting up repositories
> >Reading repository metadata in from local files
> >Excluding Packages from CentOS-5 - Base
> >Finished
> >Excluding Packages from CentOS-5 - Updates
> >Finished
> >Resolving Dependencies
> >--> Populating transaction set with selected packages. Please wait.
> >---> Package asterisk-devel.i386 1:1.4.8-42.el5 set to be updated
> >---> Package zaptel.i386 1:1.4.4-36.el5 set to be updated
> >---> Package asterisk.i386 1:1.4.8-42.el5 set to be updated
> >--> Running transaction check
> >--> Processing Dependency: perl(Zaptel::Config::Defaults) for package:
> >zaptel
> >--> Finished Dependency Resolution
> >Error: Missing Dependency: perl(Zaptel::Config::Defaults) is needed by
> >package zaptel

> This is a dependency problem with ATrpms repo--not CentOS.  I suggest
> subscribing to the ATrpms users list at
> atrpms-users at atrpms.net<../mail?view=cm&tf=0&to=atrpms-users at atrpms.net>or
> following this thread in the archives:
> http://lists.atrpms.net/pipermail/atrpms-users/2007-July/007568.html

I can confirm this to be a bug in the package (looks like an upstream
bug, but still a bug in the package), will be fixed within a couple of
Axel.Thimm at ATrpms.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.centos.org/pipermail/centos/attachments/20070724/567f315c/attachment.sig>

More information about the CentOS mailing list