[CentOS] x86_64 rpms

Matt Hyclak hyclak at math.ohiou.edu
Tue Jul 31 13:04:38 UTC 2007

On Tue, Jul 31, 2007 at 02:38:42PM +0200, David Hrbá? enlightened us:
> I'm preparing a new x86_64 build machine and I'm looking at installed
> rpms. I have found a lot of packages are marked i386 or i686. I have
> even found I have two version of package installed:
> glibc-2.3.4-2.36-i686
> glibc-2.3.4-2.36-x86_64
> What's the reason in duplicity and why not all packages are x86_64.
> Thanks in advance,
> David

Some programs are not available in 64-bit packages (e.g. openoffice). Those
packages need 32-bit libraries to run, so you are seeing the necessary
packages for those 32-bit apps.


Matt Hyclak
Department of Mathematics 
Department of Social Work
Ohio University
(740) 593-1263

More information about the CentOS mailing list