[CentOS] First install No Sound

Fri Jul 6 10:19:31 UTC 2007
Lorenzo <lorenzo at gmk.it>

Garrick Staples ha scritto:
> On Fri, Jul 06, 2007 at 05:09:46AM +0100, John Bowden alleged:
>> On Friday 06 July 2007 04:44, Garrick Staples wrote:
>>> On Fri, Jul 06, 2007 at 04:30:58AM +0100, John Bowden alleged:
>>>> The sound card is an on board one.
>>>> class: AUDIO
>>>> bus: PCI
>>>> detached: 0
>>>> desc: "nVidia Corporation MCP61 High Definition Audio"
>>>> vendorId: 10de
>>>> deviceId: 03f0
>>>> subVendorId: 1849
>>>> subDeviceId: 0862
>>>> pciType: 1
>>>> pcidom: ? ?0
>>>> pcibus: ?0
>>>> pcidev: ?5
>>>> pcifn: ?0
>>>> -
>>>> class: AUDIO
>>>> bus: ISAPNP
>>>> detached: 0
>>>> driver: snd-mpu401
>>>> desc: "PNPb006"
>>>> deviceId: PNPb006
>>>> The sound card detection program does see it but no sound come out when I
>>>> test it. I'm not sure but I think that the nvidia chip set may be quite a
>>>> new one and I'm beginning to think it might not be supported yet in
>>>> Linux.
>>> The listing for a driver implies that it is supported.  This might be a
>>> dumb question, but did you check the volume settings in the mixer app?
>> Not such a dumb question, I had tried running the alsamixer command when I had 
>> F7 installed but not after getting rid of F7 and installing CentOS. I have 
>> just tried the command from the cli and here is what I got.
>> [john at localhost ~]$ alsamixer
>> alsamixer: function snd_ctl_open failed for default: No such device
>> [john at localhost ~]$
>> When KDE starts up it gives me a error message about the sound problem. Next 
>> time I reboot I will make a note of what it is. I know that the speakers are 
>> plugged into the correct socket as this machine is one of two that dual boots 
>> windozs and I get sound when I run windoz to play games.
>> I'm off to bed now as its just past 5am so will shut down this box and have 
>> another try later on today. Thanks for the help so far though.
> That means the driver isn't loaded.  'modprobe snd-mpu401' as root and
> try again.
I have a similar board from Asrock which has apparently the same onboard audio 
card; on my FC5 install the audio module used is snd-hda-intel and the sound 
works... the relevant section in /etc/modules.conf is:

alias snd-card-0 snd-hda-intel
options snd-card-0 index=0
options snd-hda-intel index=0
remove snd-hda-intel { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; 
/sbin/modprobe -r --ignore-remove snd-hda-intel


Lorenzo Quatrini