[CentOS] monitor software does not find Belkin UPS

dcw dwoody1 at charter.net
Mon Jun 4 14:41:41 UTC 2007

I have upgraded to CentOS5 on our computers. I had been using 
Mandriva 2006. The problem I am having is that the networkupstools 
(nut-2.0.4.tar.gz) does not find the UPS device.  However, when I had 
Mandriva 2006 on the same hardware it worked.
The device manager on CentOS does show the UPS device.
The settings I used in the ups.conf file are:

driver = newhidups
port = auto

Using the same version of nut with the same config files on CentOS5, I get the 
following output from 'upsdrvctl':

Network UPS Tools - UPS driver controller 2.0.4
Network UPS Tools: New USB/HID UPS driver 0.28 (2.0.4)

No matching USB/HID UPS found
Driver failed to start (exit status=1)

The following libusb files are installed:

Using ./configure --with-user=ups the lines for libusb show:
checking for libusb cflags...
checking for libusb libs... -lusb

I posted this problem to the mailing list for the nut software. The conclusion 
is that the nut software is setup correctly.

I also downloaded and installed the latest version (nut-2.0.5.tar.gz) and got 
the same result.

All UPSs are Belkin F6H375-USB. I have searched the internet and found no 
other solutions. 

Since the software works under Mandriva 2006, I would presume that there is a 
package that is installed by default on Mandriva that is not installed by 
default on CentOS or that a config file is setup differently.

Any help will be appreciated,


More information about the CentOS mailing list