[CentOS] SSH suddenly started failing :(

John Lagrue admin at moraystudio.com
Thu Jun 7 21:41:57 UTC 2007

Paul Heinlein wrote:
> On Thu, 7 Jun 2007, John Lagrue wrote:
>> I am running a VNC onto the server, and using a window in there can 
>> switch users quite happily. But nobody can ssh into the server.
>> My only thought is that a few days ago I changed the hostname using 
>> system-network-config but I am pretty certain that I could still ssh 
>> in after doing that. It just stopped working this morning.
>> I've even tried rebooting in case there were odd processes hanging 
>> about, but that's made no difference. At the moment I'm totally stuck!
> Try a different tack. Get a root shell on the machine in question and 
> fire up sshd in no-fork mode under strace:
>   strace -o /tmp/ssh.trace sshd -D -p 2222
> Then try to ssh into that machine on port 2222 (or whatever you 
> choose). Assuming it fails, close down the temporary sshd and point 
> $PAGER at /tmp/ssh.trace. The failure point will likely be about 90% 
> of the way through the file. (The end of the file will be related to 
> closing down sshd).
I tried that, and monitored the ssh.trace file with tail-f in another 
window. There were no obvious signs of error, only what looks like a 
child starting and then exiting. Mind you, it's been a fair few years 
since I last looked at a trace file!

More information about the CentOS mailing list